View Issue Details

IDProjectCategoryView StatusLast Update
0005594SOGoWeb Mailpublic2022-10-25 07:53
ReporterHartmut Truee Assigned Tosmizrahi  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.7.1 
Fixed in Version5.8.0 
Summary0005594: Cut&Paste of email addresses not possible
Description

I want to send an email to a list of email addresses. But if I paste the list into the To: field, the addresses get not validated and the email cannot be sent.

Steps To Reproduce

Write a list of email addresses in a text file (separeted by comma, colon, tab, line break ... whatever), select and cut it and paste it into the To: field.

TagsNo tags attached.

Relationships

has duplicate 0005628 resolvedsmizrahi Pasting email addresses in recipient fields don't work 

Activities

Christian Mack

Christian Mack

2022-09-05 09:34

developer   ~0016200

Works for me.
You do know, that you need to leave the To field after copying?

If that is not your problem, which browser are you using?

Hartmut Truee

Hartmut Truee

2022-09-05 09:52

reporter   ~0016201

Yes, I know.

If I cut&paste a single address it is working as expected. I can leave the field with tab and the send arrow ist white.

If I cut&paste more than one address, I can't leave the field with tab, only by mouseclick and the send arrow remains greyed out (screenshot attached).

It is the same in current version of Firefox (104.0.1), Chrome (104.0.5112.102), Edge (105.0.1343.27), OS is Windows 10.

smizrahi

smizrahi

2022-09-05 09:53

administrator   ~0016202

It would be helpfull if you can do a video screen of your issue and as Christian says, give more details on your browser and OS

Hartmut Truee

Hartmut Truee

2022-09-05 13:58

reporter   ~0016205

After pasting multiple addresses in th TO: field there is a javascript error in the JS console:

Uncaught ReferenceError: emailRE is not defined
isValidEmail utils.js:140
addRecipient MessageEditorController.js:323
Angular 7
fn
h
appendChip
onInputBlur
Va
xg
d

JosdeK

JosdeK

2022-09-08 09:16

reporter   ~0016212

I have the same problem in Firefox 104.0.2 on my laptop running Windows 10 Home, 21H2, build 19044.1889

educomm

educomm

2022-09-12 08:26

reporter   ~0016217

Same here. We had to go back to version 5.7.0 to avoid this problem. Maybe this issue is related to https://bugs.sogo.nu/view.php?id=5581, since it is not possible to create an event in an addtional calendar in version 5.7.1 anymore.

Hartmut Truee

Hartmut Truee

2022-09-14 05:48

reporter   ~0016221

Lööks like that broke it:

https://github.com/Alinto/sogo/commit/67ccf748edcec8d495de35f431d7d0f3cf35fc6e

cuci

cuci

2022-09-15 15:36

reporter   ~0016226

We had the same issue under a host running on Debian 11 under Firefox as under Chromium. A downgrade to 5.7.0 did 'fix' this issue.

JosdeK

JosdeK

2022-09-21 07:55

reporter   ~0016234

When testing any solutions to this issue please check the removal of duplicate email addresses in a copy / paste action.
For example in v5.7.0 a paste of the following string:

user1@gmail.com user2@gmail.com user1@gmail.com user3@gmail.com

results in an incorrect email address for user3@gmail.com

See the attached screenshot.

I can't test this in v5.7.1

afbeelding.png (41,095 bytes)   
afbeelding.png (41,095 bytes)   
guymart

guymart

2022-10-05 13:50

reporter   ~0016257

We are facing the same issue in version 5.7.1.
Is there a fix or workaround instead of downgrade to 5.7.0 ? Thanks !

max.hausch

max.hausch

2022-10-20 10:25

reporter   ~0016293

indeed https://github.com/Alinto/sogo/commit/67ccf748edcec8d495de35f431d7d0f3cf35fc6e was the reason for this, but there already is a pr that fixes the issue: https://github.com/Alinto/sogo/pull/328
when applied, i can copy emails from a libreoffice calc file and after hitting tab or comma, the emails are being listed correctly

Hartmut Truee

Hartmut Truee

2022-10-20 11:57

reporter   ~0016295

Not working for me ... I changed the two lines in my 5.7.1, cleared the cache ... nope ... something missing?

Zwischenablage01.jpg (108,481 bytes)   
Zwischenablage01.jpg (108,481 bytes)   
max.hausch

max.hausch

2022-10-20 12:00

reporter   ~0016296

did you change within the browser only? or did you change the files on disk on the machine running sogo?

cuci

cuci

2022-10-20 14:25

reporter   ~0016298

I also tried the above pr fix but this doesn't seem to solve the issue. I applied it on the files on the server where SOGo is running. I receive the following error in the console after filling in the email addresses:

ReferenceError: emailRE is not defined
isValidEmail utils.js:140
addRecipient MessageEditorController.js:323
Angular 10
angular.js:15697:15

And the following after clicking to another field :

Uncaught ReferenceError: emailRE is not defined
isValidEmail utils.js:140
addRecipient MessageEditorController.js:323
Angular 7
utils.js:140:15

max.hausch

max.hausch

2022-10-21 07:10

reporter   ~0016301

the error clearly states that the file has "emailRE" on line 140 which shouldn't be the case. i rebuild the angular blob, so maybe changing the file isn't enough and you explicitly have to tell angular to include the file. so maybe you are missing a grunt build in the right directory before the front end "sees" the changes. otherwise you could probably write "asdf" in line 140 in the utils.js file and it would still complain about "emailRE not defined". hope that helps

Hartmut Truee

Hartmut Truee

2022-10-21 10:10

reporter   ~0016302

I am not a SOGo developer, so hopefully I did the right things...: I modified the UI/WebServerResources/js/Common/utils.js according to the pull request and builded the frontend as described in the Developers Guide chapter 4. Then I copied the modified js files to out test environment.

And now it works, I can copy and paste email addresses again!

When will the pull request be merged in the master?

smizrahi

smizrahi

2022-10-25 07:52

administrator   ~0016312

Hi,

PR https://github.com/Alinto/sogo/pull/328/files has been merged it should be available on latest nightly and should fix that issue.

Sebastien

Issue History

Date Modified Username Field Change
2022-09-02 09:12 Hartmut Truee New Issue
2022-09-05 09:34 Christian Mack Note Added: 0016200
2022-09-05 09:52 Hartmut Truee Note Added: 0016201
2022-09-05 09:52 Hartmut Truee File Added: Screenshot 2022-09-05 at 11-39-39 Uni-Hildesheim-SOGo.png
2022-09-05 09:53 smizrahi Note Added: 0016202
2022-09-05 13:58 Hartmut Truee Note Added: 0016205
2022-09-08 09:16 JosdeK Note Added: 0016212
2022-09-12 08:26 educomm Note Added: 0016217
2022-09-14 05:48 Hartmut Truee Note Added: 0016221
2022-09-14 07:08 smizrahi Assigned To => smizrahi
2022-09-14 07:08 smizrahi Status new => assigned
2022-09-15 15:36 cuci Note Added: 0016226
2022-09-21 07:55 JosdeK Note Added: 0016234
2022-09-21 07:55 JosdeK File Added: afbeelding.png
2022-10-05 13:50 guymart Note Added: 0016257
2022-10-20 10:25 max.hausch Note Added: 0016293
2022-10-20 11:57 Hartmut Truee Note Added: 0016295
2022-10-20 11:57 Hartmut Truee File Added: Zwischenablage01.jpg
2022-10-20 12:00 max.hausch Note Added: 0016296
2022-10-20 12:04 Christian Mack Relationship added has duplicate 0005628
2022-10-20 14:25 cuci Note Added: 0016298
2022-10-21 07:10 max.hausch Note Added: 0016301
2022-10-21 10:10 Hartmut Truee Note Added: 0016302
2022-10-25 07:52 smizrahi Note Added: 0016312
2022-10-25 07:53 smizrahi Status assigned => resolved
2022-10-25 07:53 smizrahi Resolution open => fixed
2022-10-25 07:53 smizrahi Fixed in Version => 5.8.0