View Issue Details

IDProjectCategoryView StatusLast Update
0005574SOGoGUIpublic2022-09-05 16:19
Reporterwar Assigned Tosmizrahi  
PriorityhighSeverityblockReproducibilityalways
Status feedbackResolutionreopened 
PlatformServerOSUbuntuOS Version22.04
Product Version5.5.1 
Summary0005574: After release upgrade SOGo does not provide HTML Interface
Description

Ubuntu 20.04 LTS -> 22.04 release upgrade deletes SOGo 5.7.1. nightly
A repo version 5.5.1-1 is provided (I installed that).

After installation, HTML frontend was broken (see uploaded file).
Login is not possible (the logon arrow is not shown, the text has no click handler).

There is no entry in the error log or the access log. The call to myserver.com/SOGo is recorded.

Steps To Reproduce
  1. Have 5.7.1 nightly installed on Ubuntu 20.04
  2. do-release-upgrade
  3. https://myserver.com/SOGo
  4. -> no frontend to logon, no logon, no mails
Additional Information

Cal/Carddav work fine, indicating that the apache configuration and behind-the-scene sogo is working.

SOGo configuration seems working.

I use HTTPS root for SOGo. I presume (but not sure) it must have to do with the apache2 site configuration.

On the logon page, there are several javascript tags that are empty. Is that correct?

TagsNo tags attached.

Relationships

duplicate of 0005511 confirmedsmizrahi Build packages for Ubuntu 22.04 LTS 

Activities

war

war

2022-08-14 12:41

reporter  

jan

jan

2022-08-15 05:07

reporter   ~0016162

Did you do the SQL Updates from /usr/share/doc/sogo
I assume you might need sql-update-5.5.1_to_5.6.0.sh

war

war

2022-08-15 09:52

reporter   ~0016164

Last edited: 2022-08-19 12:34

I have 5.5.1 installed and there is no such script as a sql-update-5.5.1_to_5.6.0.sh (the last being sql-update-3.2.10_to_4.0.0.sh)

also there is no error in the log indicating an error related to database schema.

sogo-log:

Aug 15 11:50:00 sogod [17689]: version 5.5.1 -- starting
Aug 15 11:50:00 sogod [17689]: vmem size check enabled: shutting down app when vmem > 384 MB. Currently at 90 MB
Aug 15 11:50:00 sogod [17689]: <0x0x561d29f7d700[SOGoProductLoader]> SOGo products loaded from '/usr/lib/GNUstep/SOGo':
Aug 15 11:50:00 sogod [17689]: <0x0x561d29f7d700[SOGoProductLoader]>   ContactsUI.SOGo, PreferencesUI.SOGo, MailerUI.SOGo, MainUI.SOGo, AdministrationUI.SOGo, Contacts.SOGo, Appointments.SOGo, MailPartViewers.SOGo, CommonUI.SOGo, Mailer.SOGo, SchedulerUI.SOGo
Aug 15 11:50:00 sogod [17689]: All products loaded - current memory usage at 97 MB
Aug 15 11:50:00 sogod [17689]: <0x0x561d29fcc4a0[WOWatchDog]> listening on 127.0.0.1:20000
Aug 15 11:50:00 sogod [17689]: <0x0x561d29fcc4a0[WOWatchDog]> watchdog process pid: 17689
Aug 15 11:50:00 sogod [17689]: <0x0x7fb7b1ba2360[WOWatchDogChild]> watchdog request timeout set to 10 minutes
Aug 15 11:50:00 sogod [17689]: <0x0x561d29fcc4a0[WOWatchDog]> preparing 3 children
Aug 15 11:50:00 sogod [17689]: <0x0x561d29fcc4a0[WOWatchDog]> child spawned with pid 17690
Aug 15 11:50:00 sogod [17689]: <0x0x561d29fcc4a0[WOWatchDog]> child spawned with pid 17691
Aug 15 11:50:00 sogod [17689]: <0x0x561d29fcc4a0[WOWatchDog]> child spawned with pid 17692
Aug 15 11:50:00 sogod [17692]: <0x0x561d29ffe460[WOHttpAdaptor]> notified the watchdog that we are ready
Aug 15 11:50:00 sogod [17691]: <0x0x561d29ffe460[WOHttpAdaptor]> notified the watchdog that we are ready
Aug 15 11:50:00 sogod [17690]: <0x0x561d2a00e6c0[WOHttpAdaptor]> notified the watchdog that we are ready

syslog:

Aug 15 11:49:58 s4 systemd[1]: Stopping SOGo is a groupware server...
Aug 15 11:50:00 s4 systemd[1]: sogo.service: Deactivated successfully.
Aug 15 11:50:00 s4 systemd[1]: Stopped SOGo is a groupware server.
Aug 15 11:50:00 s4 systemd[1]: sogo.service: Consumed 1.180s CPU time.
Aug 15 11:50:00 s4 systemd[1]: Starting SOGo is a groupware server...
Aug 15 11:50:00 s4 systemd[1]: Started SOGo is a groupware server.

seems smooth

war

war

2022-08-15 10:01

reporter   ~0016165

I did some research on the installation:

  1. Nightly build and Ubuntu repo use different installation directories (Templates and WebServerResources are in /usr/share/in Ubuntu while in /usr/lib in Nightly)
  2. I completely removed and reinstalled the repo version (which uses a more up-to-date libgnustep-base1.28)

sogo seems to work now but the web frontend, cal- and carddav connectors are missing.

To get this, I need to set up a virtual host on the web server.

There used to be a template (contained path and access rights to some internal directories) which I cannot find any more.

Current situation:
sogod -> up and running
web -> missing configuration

Is there a place I can find it?

abma

abma

2022-08-19 06:06

reporter   ~0016174

just a guess:

do you have configured "localhost" as imap server in sogo.conf?

if so, you could try to change it to 127.0.0.1: this forces usage of ipv4. sogo 4.71 introduces ipv6 support...

war

war

2022-08-19 11:00

reporter   ~0016176

Current findings and resolution:

  1. the Ubuntu sogo package lacks the SOGo.conf file for Apache -> No web frontend with this package out of the box

  2. SOGo documentation has the sample config file deleted (it was in previous documentations that I luckily downloaded)

  3. Re-Installing sogo from scatch (after completely cleaning all remains of previous installations and nightly's) -> sogo runs as a daemon

  4. Recover a backup of my previous Apache config file for my virtual host allows web frontend but no content. Cards and Cal works in the web frontend and as services

  5. NO exchanging 127.0.0.1 with 127.0.0.1: or localhost does not change anything (please refer to the GNUStep source code to see why).

  6. Blank page after logon -> the syslog records logon denies. This is due to default (selfsigned) snakeoil.pem certificates. Server name and port mismatches for
    SOGoIMAPServer = imaps://<server_name_as_in_certificate>:993
    If server name matches, make sure port 993 for imaps is selected (depending on MTA-config)
    => DO NOT USE "/?tls=YES" after the port.

  7. Be aware of Apache configuration. Apache2 has a defined structure with configurations, sites, modules and ports (only the first two are relevant). If you use virtual servers, do not enable the configuration. Rather set a default site that points to an error page.
    There are some rewrites and aliases in the configuration that make SOGo a pain in the neck administering (there are two nearly identical directory branches in /usr/lib and /usr/share and it is not obvious, which branch is taken - due to symlinks between the two)

=> IT WOULD BE APPRECIATED IF THE SOGO TEAM WOULD PROVIDE A SAMPLE APACHE CONFIG FOR REFERENCE!!! (Thanks)

smizrahi

smizrahi

2022-08-19 11:30

administrator   ~0016177

Hi war,

would this help ? https://www.sogo.nu/files/docs/apache/SOGo.conf

If this is what your looking for I will update documentation on website

war

war

2022-08-19 11:34

reporter   ~0016178

Last edited: 2022-08-19 12:33

Yes, if it was available from the documentation, it should serve as a starting point.

Embedding it as a virtual host could be left to the administrator (URL rewrites, SSL). There was an amendment related to Apples CalDav and CardDav.

# For Apple autoconfiguration
&lt;IfModule rewrite_module>
RewriteEngine On
RewriteRule ^/.well-known/caldav/?$ /SOGo/dav [R=301]
RewriteRule ^/.well-known/carddav/?$ /SOGo/dav [R=301]
&lt;/IfModule>
abma

abma

2022-08-19 11:36

reporter   ~0016179

for me it looks like there are no packages for ubuntu 22.04: https://www.sogo.nu/download.html

so the 20.04 sogod compatible possible just crashes on ubuntu 22.04.

abma

abma

2022-08-19 11:37

reporter   ~0016180

-> compile sogo yourself for ubuntu 22.04 or ask the sogo team to provide packages for it.

smizrahi

smizrahi

2022-08-19 12:26

administrator   ~0016181

Hey there, a new entry in FAQ has been added : https://www.sogo.nu/support/faq/how-to-configure-apache-as-frontend.html

For Ubuntu 22.04 compatibility, this would be great as this is a LTS version. Put it in my todo.

smizrahi

smizrahi

2022-09-05 10:00

administrator   ~0016204

Hi, as, this a duplicate of 0005511 I suggest to close this ticket. Let me know if you want to keep it opened.

war

war

2022-09-05 14:22

reporter   ~0016206

I would not consider this a duplicate:

5511 requests a dedicated package for Ubuntu 22.04 (like was available for 20.04 for SOGo 5.7.1)
This issue - 5574 - has to do with a repo package 5.5.1 that fails to deliver the web configuration.

=> 5511 does not exist
=> 5574 exists but is outdated and broken

The forum entry (https://www.sogo.nu/support/faq/how-to-configure-apache-as-frontend.html) is a fragment that needs to be embedded into a virtual host definition or added as a configuration but as is does not help either.

All in all, SOGo requires deep administrative skills to install either on Ubuntu (and as I've come to learn) Fedora server. It is not an install-and-forget service as it used to be.

smizrahi

smizrahi

2022-09-05 16:19

administrator   ~0016207

Ok thanks for clarification

Issue History

Date Modified Username Field Change
2022-08-14 12:41 war New Issue
2022-08-14 12:41 war File Added: Screenshot 2022-08-14 at 14.19.45.png
2022-08-15 05:07 jan Note Added: 0016162
2022-08-15 09:52 war Note Added: 0016164
2022-08-15 10:01 war Note Added: 0016165
2022-08-19 06:06 abma Note Added: 0016174
2022-08-19 11:00 war Note Added: 0016176
2022-08-19 11:30 smizrahi Note Added: 0016177
2022-08-19 11:34 war Note Added: 0016178
2022-08-19 11:36 abma Note Added: 0016179
2022-08-19 11:37 abma Note Added: 0016180
2022-08-19 12:26 smizrahi Note Added: 0016181
2022-08-19 12:33 francis Note Edited: 0016178
2022-08-19 12:34 francis Note Edited: 0016164
2022-09-05 10:00 smizrahi Relationship added duplicate of 0005511
2022-09-05 10:00 smizrahi Note Added: 0016204
2022-09-05 13:41 smizrahi Assigned To => smizrahi
2022-09-05 13:41 smizrahi Status new => closed
2022-09-05 13:41 smizrahi Resolution open => duplicate
2022-09-05 14:22 war Status closed => feedback
2022-09-05 14:22 war Resolution duplicate => reopened
2022-09-05 14:22 war Note Added: 0016206
2022-09-05 16:19 smizrahi Note Added: 0016207