View Issue Details

IDProjectCategoryView StatusLast Update
0005887SOGoWeb Mailpublic2023-10-11 13:04
Reporterrof Assigned Toqhivert  
Status closedResolutionfixed 
Product Version5.9.0 
Fixed in Version5.10.0 
Summary0005887: "download message" as eml sends content mimetype "application/zip"

After updating to SOGo 5.9 (or Firefox ESR 115.3 - which happened at the same time), SOGo tries to open a zip utility when downloading a message.
Because we have linked the mimetype "application/zip" in Firefox to an archive programm, download is automatically opened, which again fails. In the post headers you can see the wrong request "Accept: application/zip", in the answer it correctly says "Content-Type: message/rfc822; charset=utf-8".

Steps To Reproduce
  1. login at
  2. choose an email
  3. then click the hamburger button and select the option "Download message".
  4. the file is displayed in Firefox as a zip file and wants to be processed as such, but is in real a valid eml file
TagsNo tags attached.




2023-10-10 15:51

administrator   ~0017353

Last edited: 2023-10-10 15:52

Well I've just tried it with last version of firefox and chrome and I have a correct EML file or a correct zip. Could you try with something else than firefox ESR?

donwload.png (241,530 bytes)   
donwload.png (241,530 bytes)   


2023-10-10 16:16

reporter   ~0017354

I think you can understand it if you change the action for zip files from "Download" to "Always ask" in the FF settings (see example in in Archlinux with FF 118.0.1 resulted in the same error.



2023-10-11 08:26

administrator   ~0017360

Yes I see it now. I'll get a look a that.
However, when I save the file, it's correctly downloaded as an eml file and not a zip file. Is it your case too?

donwloadzip.png (215,668 bytes)   
donwloadzip.png (215,668 bytes)   


2023-10-11 09:13

reporter   ~0017361

Yes that is the same with us!
Since zip files are opened by default in our system with archiver, it tries to open eml file in it. This then unfortunately fails.



2023-10-11 09:34

administrator   ~0017363

Ok i've made a fix ->
It will be available with the nightly tomorrow morning, let me know if it works now.



2023-10-11 09:56

reporter   ~0017364

Thanks for the quick fix, I will report back!



2023-10-11 12:30

reporter   ~0017365

Because it was only a js-file, we changed it ourselves in the code immediately and tested: it works!
Thank you very much again!



2023-10-11 13:04

administrator   ~0017366

Glad I could help! I'll close this issue.

Issue History

Date Modified Username Field Change
2023-10-10 15:27 rof New Issue
2023-10-10 15:51 qhivert Note Added: 0017353
2023-10-10 15:51 qhivert File Added: donwload.png
2023-10-10 15:52 qhivert Note Edited: 0017353
2023-10-10 15:52 qhivert Assigned To => qhivert
2023-10-10 15:52 qhivert Status new => feedback
2023-10-10 16:16 rof Note Added: 0017354
2023-10-10 16:16 rof Status feedback => assigned
2023-10-11 08:26 qhivert Note Added: 0017360
2023-10-11 08:26 qhivert File Added: donwloadzip.png
2023-10-11 08:26 qhivert Status assigned => feedback
2023-10-11 09:13 rof Note Added: 0017361
2023-10-11 09:13 rof Status feedback => assigned
2023-10-11 09:34 qhivert Note Added: 0017363
2023-10-11 09:34 qhivert Status assigned => feedback
2023-10-11 09:56 rof Note Added: 0017364
2023-10-11 09:56 rof Status feedback => assigned
2023-10-11 12:30 rof Note Added: 0017365
2023-10-11 13:04 qhivert Note Added: 0017366
2023-10-11 13:04 qhivert Status assigned => closed
2023-10-11 13:04 qhivert Resolution open => fixed
2023-10-11 13:04 qhivert Fixed in Version => 5.10.0