View Issue Details

IDProjectCategoryView StatusLast Update
0005858SOGoWeb Mailpublic2023-09-14 09:35
ReporterBaggypants Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Product Version5.8.4 
Summary0005858: Using LDAP to list identities creates unspecified-domain entries

I'm using an old LDAP system from ClearOS, it stores email identities as the name part only. When I try to use those identities it allows me to pick the name and send the email but does not append the domain to the address so in the sent folder I have <identity>@unspecified-domain

This is my ldap config

    SOGoUserSources = (
            type = ldap;
            CNFieldName = cn;
/*            IDFieldName = cn;*/
            MailFieldNames = (
            UIDFieldName = uid;
            baseDN = "ou=Users,ou=Accounts,dc=therobinsonfamily,dc=net";
            bindDN = "cn=manager,ou=internal,dc=therobinsonfamily,dc=net";
            bindFields = (
            bindPassword = redacted;
            canAuthenticate = YES;
            displayName = "Local Addresses";
            filter = "(objectClass = clearMailAccount)";
            id = public;
            isAddressBook = NO;
            hostname = ldaps://gateway.clarkconnect.lan:636;

I'd like a way of appending the domain so it records the outgoing email correctly.

I'm certain it worked way back in Sogo v2

TagsNo tags attached.


There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2023-09-14 09:35 Baggypants New Issue