View Issue Details

IDProjectCategoryView StatusLast Update
0005716SOGoWeb Mailpublic2023-03-27 08:49
Reporterskankhunt42 Assigned To 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status newResolutionopen 
Product Version5.8.0 
Summary0005716: New Identity generates faulty JSON


I'm using SoGo 5.8.0 as part of Mailcow. (related issue:

I've added a new Identity for my account via SoGo Webclient to send mails with a different sender address. This worked fine for the first 4 different identities.
After creating the 5th, logging out and logging back in (authentication successful), I only see a JSON object with my identities instead of the Inbox view.

It seems, that the generated json (stored in sogo_user_profile) is corrupt. After "SoGoMailIdentities" there is some weird pipe but I'm not sure if this is by purpose or the source of the error. (I added some snippets to the Github Issue)

I am not entirely sure if it's safe to touch the database entry or just drop it entirely. What would be the best way to at least reset the identities without breaking everything?

Tagsidentity, web, webmail




2023-03-27 07:44

administrator   ~0016761

Hi, I did not reproduced this issue ont my dev env. Could you please provide :

  • the generated json code
  • Erros in JS console




2023-03-27 08:49

reporter   ~0016762

Hi Sebastien,

I posted a snippet of the generated json on GitHub. Is this sufficient?

Where to get the errors from the JS console?

But I guess, I already found the issue here. Some chrome plugin injected something in the signature field. This might have broken it:
This is what appears as error in browser:

Uncaught SyntaxError: Invalid or unexpected token (at view:48:400)
The affected line:
var mailAccounts = [{"specialMailboxes":{"Sent":"Sent","Trash":"Trash","Junk":"Junk","Drafts":"Drafts","Templates":"Templates"},"encryption":"none","tlsVerifyMode":"none","port":143,"delegates":[],"name":"","serverName":"","userName":"","identities":[{"email":"","fullName":"admin","isDefault":1,"signature":"<br /><script src=\"chrome-extension://XYZ/inpage.js\" id=\"XYZ\"></script>"}, {"email":"","replyTo":"","fullName":"Some Name","signature":"<br /><script src=\"chrome-extension://XYZ/inpage.js\" id=\"XYZ\"></script>"}, {"fullName":"SOME NAME","email":"","signature":"<br /><script src=\"chrome-extension://XYZ/inpage.js\" id=\"XYZ\"></script>"}, {"fullName":"Name","email":"","signature":"<br /><script src=\"chrome-extension://XYZ/inpage.js\" id=\"XYZ\"></script>"}, {"fullName":"Name Name","email":"","signature":"<br /><script src=\"chrome-extension://XYZ/inpage.js\" id=\"XYZ\"></script><script src=\"chrome-extension://XYZ/inpage.js\" id=\"XYZ\"></script>"}, {"fullName":"Some Twitter","email":"","signature":""}]}];

So it looks like this wasn't properly escaped? (It shouldn't be there at all in the first place, I will contact the creator of that extension too)


Issue History

Date Modified Username Field Change
2023-03-24 08:10 skankhunt42 New Issue
2023-03-24 08:10 skankhunt42 Tag Attached: identity
2023-03-24 08:10 skankhunt42 Tag Attached: web
2023-03-24 08:10 skankhunt42 Tag Attached: webmail
2023-03-27 07:44 sebastien Note Added: 0016761
2023-03-27 08:49 skankhunt42 Note Added: 0016762