View Issue Details

IDProjectCategoryView StatusLast Update
0005486SOGoActiveSyncpublic2022-03-03 20:02
ReporterFoZo Assigned Tofrancis  
Status resolvedResolutionfixed 
Product Version5.5.1 
Fixed in Version5.6.0 
Summary0005486: xml2wbxmlFromContent: failed: Parsing of XML Document Failed

Active synk is not working after upgrade. I am not sure if it is sogo or sope error, because even after downgrading sogo, I am getting the same problem.

Feb 24 11:36:48 sogod [5038]: [ERROR] <0x0x55673774e410[NSDataMalloc]> xml2wbxmlFromContent: failed: Parsing of XML Document Failed
Feb 24 11:36:48 sogod [5038]: [ERROR] <0x0x55673774e410[NSDataMalloc]> Original data written to: /tmp/

xmllint --format /tmp/ is formatting the content without a problem.

What I tried so far.

  • Doubled the SxVMemLimit
  • Lowered SOGoMaximumSyncWindowSize
  • Reinstalling sope
  • Downgrading sogo.
Steps To Reproduce

Update sope and sogo to the latest nightly version

Additional Information

Ubuntu 18.04.6

TagsNo tags attached.




2022-02-24 11:01

reporter   ~0015914

I am getting the same issue on another instance of sogo.



2022-02-24 12:46

reporter   ~0015915

Another note. The tests were done by using various Outlook versions as clients.



2022-02-24 13:43

reporter   ~0015916

We received few same reports from iRedMail users (



2022-02-24 14:31

administrator   ~0015917

Can you try downgrading your version of libexpat1?

It has been the solution under Debian. See



2022-02-24 15:14

reporter   ~0015918

Last edited: 2022-02-24 15:17

How did I missed that?!
Thank you!

I was stuck with the libwbxml2 library.

How I temporally solved the issue:

For Ubuntu18.04:

apt-get install libexpat1=2.2.5-3 libexpat1-dev=2.2.5-3
apt-mark hold libexpat1

For Ubuntu 20.04:

apt-get install libexpat1=2.2.9-1build1 libexpat1-dev=2.2.9-1build1
apt-mark hold libexpat1


2022-02-27 19:52

reporter   ~0015921

I am also getting this issue as well on ArchLinux,

As a work around I down grading expat to 2.4.4 and that fixed the problem for me. I think the problem was introduced in 2.4.5 with one of the CVE patches



2022-02-27 21:15

reporter   ~0015922

Hi all,

On further investigation I found the cause of this problem it is related to libwbxml

Patching libwbxml with that pull request allows SOGo to work with the latest expat.

Please dont downgrade expat as CVE-2022-25235 has a critical base score of 9.8



2022-03-03 19:57

administrator   ~0015928

New packages are available from

Issue History

Date Modified Username Field Change
2022-02-24 10:44 FoZo New Issue
2022-02-24 11:01 FoZo Note Added: 0015914
2022-02-24 12:46 FoZo Note Added: 0015915
2022-02-24 13:43 zhb Note Added: 0015916
2022-02-24 14:27 francis Description Updated
2022-02-24 14:31 francis Note Added: 0015917
2022-02-24 15:14 FoZo Note Added: 0015918
2022-02-24 15:17 francis Note Edited: 0015918
2022-02-27 19:52 slainsavage Note Added: 0015921
2022-02-27 21:15 slainsavage Note Added: 0015922
2022-03-03 19:57 francis Assigned To => francis
2022-03-03 19:57 francis Status new => resolved
2022-03-03 19:57 francis Resolution open => fixed
2022-03-03 19:57 francis Fixed in Version => 5.6.0
2022-03-03 19:57 francis Note Added: 0015928