View Issue Details

IDProjectCategoryView StatusLast Update
0005251SOGoWeb Generalpublic2023-02-23 11:15
ReporterTimSch Assigned To 
PrioritynormalSeverityblockReproducibilityhave not tried
Status newResolutionopen 
Summary0005251: ACL card invisible when trying to share

When I try to share a folder, the ACL card to choose the correct permissions is hidden.

It's possible to search the user.
After clicking the user, he's shown in the list below the search field but I can't choose any permissions, even if I click on the user entry.

After some investigation, I found out, that the corresponding card has the class "ng-hide".
When I removed this class, the card is shown and I successfully shared the folder.

TagsNo tags attached.




2021-01-25 13:56


dev-tool.PNG (17,650 bytes)   
dev-tool.PNG (17,650 bytes)   
modal.PNG (15,776 bytes)   
modal.PNG (15,776 bytes)   


2021-01-25 14:12

administrator   ~0015058

Any error in your JavaScript console?



2021-01-25 14:25

reporter   ~0015059

neither in the console nor in the log file.

There seem to be more (possible) JS issues:
Clicking on the switch to (de)activate a calendar has no effect.
The calendar is always visible.

Other parts work, the fullscreen button of the calendar is responding for example.

console.PNG (18,229 bytes)   
console.PNG (18,229 bytes)   


2021-01-25 14:28

reporter   ~0015060

I tried this on three different browsers (Chrome, Firefox and IE). I disabled my ad/scriptblocker on Chrome. There is definitely no JS suppressed.



2023-02-17 08:13

reporter   ~0016660

I do experience exactly the same issue on a multi domain setup of SOGo. In the 'network' view of the browsers' debugger I am able to see the search request going to the server and the results coming back (this works just fine and the results are correct and limited to the domain), but they never get displayed in any way.
When querying for 'demo' I can see a request going out to that is receiving a response like this:
{"users":[{"isGroup":0,"c_email":"","cn":"Demo User","uid":"demo"}]}
Any idea how to debug the issue?



2023-02-20 09:38

administrator   ~0016665

You can firs enable SOGoUIxDebugEnabled = YES;. Can you reproduce this on ?



2023-02-20 14:16

reporter   ~0016667

Thank you very much for getting back to me! The issue isn't reproducible on

It is also not reproducible on another single domain instance I operate. Just on a multi domain instance with several small domains this behavior is shown. When enabling SOGoUIxDebugEnabled the browsers' console shows an empty array after the XHR request. The server response to the XHR request looks identical on both SOGo instances and contains valid json.



2023-02-23 11:15

administrator   ~0016683

Would it be possible to provide an access to your instance ?

Issue History

Date Modified Username Field Change
2021-01-25 13:56 TimSch New Issue
2021-01-25 13:56 TimSch File Added: dev-tool.PNG
2021-01-25 13:56 TimSch File Added: modal.PNG
2021-01-25 14:12 francis Note Added: 0015058
2021-01-25 14:25 TimSch Note Added: 0015059
2021-01-25 14:25 TimSch File Added: console.PNG
2021-01-25 14:28 TimSch Note Added: 0015060
2023-02-17 08:13 adi Note Added: 0016660
2023-02-20 09:38 sebastien Note Added: 0016665
2023-02-20 14:16 adi Note Added: 0016667
2023-02-23 11:15 sebastien Note Added: 0016683