View Issue Details

IDProjectCategoryView StatusLast Update
0004392SOGoWeb Preferencespublic2018-03-09 17:43
ReporterASolana Assigned Tofrancis  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version3.2.10 
Summary0004392: All sieve filters disabled on imap server when saving Sogo filters preferences.
Description

Saving filters preferences can disable all user sieve filters on an imap server if this imap server doesn't suport the imap4extension used in some sogo sieve filters.

Sogo would have to check imap server capabilities before trying to save new filters.

Steps To Reproduce
Sogo 3.2.10 on Ubuntu 16.04

An imap server (cyrus 2.4.17) with sieve filtering enabled without imap4extension capability support.

  1. UserA has some active mail sieve filters on imap server.

  2. UserA creates a new filter in SOGO using imap4extension extension (p.e. adding a Seen tag to messages)

  3. UserA trys to save new filters configuration but imap server returns an error and then:

  • Sogo displays a "Connection error" message to userA
  • Active sieve filter file is deleted on imap server.
  1. At this point no sieve filters are enabled for UserA on imap server.

If user doesn't fix his filter configuration it has no active filters.

To fix it, UserA must remove filter which adds a tag, then configuration can be saved succesfully and Imap server enables UserA sieve filters file again.

Additional Information
- Cyrus log

Feb 7 18:54:19 nobel1 master[9499]: about to exec /usr/lib/cyrus/bin/timsieved
Feb 7 18:54:19 nobel1 cyrus/sieve[9499]: executed
Feb 7 18:54:19 nobel1 cyrus/sieve[9499]: accepted connection
Feb 7 18:54:19 nobel1 cyrus/sieve[9499]: login: leonard3.upc.edu[147.83.2.22] usuari^ana PLAIN User logged in
Feb 7 18:54:19 nobel1 cyrus/sieve[9499]: line 1: Unsupported feature(s) in "require": "imap4flags"0000015
Feb 7 18:54:19 nobel1 cyrus/sieve[9499]: Lost connection to client -- exiting

  • SOGO log

Feb 07 18:54:19 sogod [32062]: |SOGo| starting method 'POST' on uri '/SOGo/so/usuari.ana/Preferences/save'
Feb 07 18:54:19 sogod [32062]: <0x0x55ee3e51be70[SOGoSieveManager]> Could not upload Sieve script: {RawResponse = "{ok = 0; reason = \"script errors:
line 1: Unsupported feature(s) in \\"require\\": \\"imap4flags\\"
\"; }"; result = 0; }
Feb 07 18:54:19 sogod [32062]: |SOGo| request took 0.281449 seconds to execute
Tags

Tagsconfiguration, filters, sieve

Activities

francis

francis

2018-02-14 02:43

administrator   ~0012600

Did the Sieve server capabilities changed while sogod was running? In this case sogod has to be restarted.

ASolana

ASolana

2018-03-09 14:08

reporter   ~0012644

The unsupported extension name is "imap4flags" (not imap4extension, a mistake).

francis

francis

2018-03-09 14:41

administrator   ~0012645

SOGo won't offer actions related to imap4flags if the extension is not listed in the server's capabilities.

Was imap4flags disabled once users had already defined filters using this extension (add/remove flag)?

ASolana

ASolana

2018-03-09 17:13

reporter   ~0012647

Thanks for your last comment, it has help me a lot.

I've discovered a misconfiguration in our imap proxy servers: they were offering imap4flags extension but sieve servers doesn't supported it.

I've configured same sieve extensions in imap proxy servers and the issue cannot be reproduced now.

Issue History

Date Modified Username Field Change
2018-02-07 18:39 ASolana New Issue
2018-02-07 18:44 ASolana Tag Attached: configuration
2018-02-07 18:44 ASolana Tag Attached: filters
2018-02-07 18:44 ASolana Tag Attached: sieve
2018-02-14 02:43 francis Note Added: 0012600
2018-03-09 14:08 ASolana Note Added: 0012644
2018-03-09 14:41 francis Note Added: 0012645
2018-03-09 17:13 ASolana Note Added: 0012647
2018-03-09 17:43 francis Status new => closed
2018-03-09 17:43 francis Assigned To => francis
2018-03-09 17:43 francis Resolution open => no change required