View Issue Details

IDProjectCategoryView StatusLast Update
0003894SOGo Connectorwith external serverpublic2018-03-16 18:58
ReporterpbSogo Assigned Toludovic  
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version24
Product Version31.0.3 
Fixed in Version31.0.6 
Summary0003894: Thunderbird 45.4.0 will not proper create new remote addressbook

Using Thunderbird 45.4.0 on Fedora 24 (latest, all updates applied), I can't add a new remote address book properly.

New -> New Remote Address Book
Enter name + URL -> OK

console shows:

exception getting pref '':
[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://sogo-connector/content/general/preference.service.addressbook.groupdav.js :: GdPSvc__getPref :: line 126" data: no] (126)

Verifying current Thunderbird's about:config shows that preference, but once Thunderbird is terminated and restarted, the created addressbook (here: "RemoteTest3") appears to be a local one and the preference from above created during creation is gone.

Steps To Reproduce

See above

Additional Information

have tried also older sogo-connector versions and nighly build, all with same behavior

TagsNo tags attached.




2016-11-13 10:26

reporter   ~0010843

on a second system/client (also Thunderbird on Linux) the same error occurs during adding a new remote address book, but preference is persistent after restart, probably an improper close of Thunderbird resulted in the loss.

Christian Mack

Christian Mack

2016-11-14 11:10

developer   ~0010846

Which version of SOGo Connector have you installed?



2016-11-14 18:22

reporter   ~0010848

SOGo connector 31.0.3, but afair also seen with 31.0.4 from nightly build

Christian Mack

Christian Mack

2016-11-15 10:29

developer   ~0010853

This is just a hunch, could you check, if there is a blank before or after the URL?



2016-11-16 06:40

reporter   ~0010870

It's depending on the sequence and error message is related to

start thunderbird -> new remote AB -> CTRL-C -> restart thunderbird -> AB is local, SOGo settings lost

start thunderbird -> new remote AB -> close thunderbird -> restart thunderbird -> AB is remote, SOGo settings kept

start thunderbird -> new remote AB -> new entry in remote AB -> CTRL-C -> restart thunderbird -> AB is remote, SOGo settings kept

looks like in 1) a preference sync/commit is missing right after the creation



2018-03-16 18:58

administrator   ~0012744

Issue History

Date Modified Username Field Change
2016-11-13 08:14 pbSogo New Issue
2016-11-13 10:26 pbSogo Note Added: 0010843
2016-11-14 11:10 Christian Mack Note Added: 0010846
2016-11-14 18:22 pbSogo Note Added: 0010848
2016-11-15 10:29 Christian Mack Note Added: 0010853
2016-11-16 06:40 pbSogo Note Added: 0010870
2018-03-16 18:58 ludovic Note Added: 0012744
2018-03-16 18:58 ludovic Status new => resolved
2018-03-16 18:58 ludovic Fixed in Version => 31.0.6
2018-03-16 18:58 ludovic Resolution open => fixed
2018-03-16 18:58 ludovic Assigned To => ludovic