View Issue Details

IDProjectCategoryView StatusLast Update
0001279SOGoBackend Generalpublic2017-01-06 19:57
Reportermsuchy Assigned Tojraby 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionopen 
Product Versionnightly v2 
Summary0001279: Init.d script errors on RHEL6
Description

I have RHEL6 on x86_64. When I start sogod service I got this error:

[root@posta ~]# /etc/init.d/sogod start
/etc/init.d/sogod: line 73: /usr/GNUstep/System/Library/Makefiles/GNUstep.sh: Directory or file does not exist
Starting SOGo:
2011-05-04 21:37:49.065 sogod[7632] File NSData.m: 157. In readContentsOfFile Open ((nil)) attempt failed - bad path
sogo [ OK ]

I'm just focusing on first error right now. When I apply this patch:

--- /etc/init.d/sogod.bak 2011-05-04 21:39:37.436465240 +0200
+++ /etc/init.d/sogod 2011-05-04 21:40:04.376472378 +0200
@@ -70,7 +70,7 @@
. /etc/rc.d/init.d/functions
if [ -z "$GNUSTEP_SYSTEM_ROOT" ]
then

  • . /usr/GNUstep/System/Library/Makefiles/GNUstep.sh
  • . /usr/lib64/GNUstep/Makefiles/GNUstep.sh
    fi

    DAEMON_OPTS="-WOWorkersCount $PREFORK -WOPidFile $PIDFILE -WOLogFile $LOGFILE"

Error goes away.
Of course this could not be generaly applied as on i386 the path will be probably just /usr/lib/GNUstep...

Additional Information

rpm -q sogo

sogo-1.3.7-1.el6.0.x86_64

TagsNo tags attached.

Activities

jraby

jraby

2011-05-06 12:59

viewer   ~0002434

My guess is that you have installed gnustep-make from EPEL since the rpm provided by the Inverse repo should install under /usr/GNUstep/.

Can you try with the rpm provided by Inverse?

jraby

jraby

2011-05-06 13:10

viewer   ~0002435

To do that, you can exclude gnustep-* from epel.

/etc/yum.repos.d/epel.repo:
[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
exclude=gnustep-*

msuchy

msuchy

2011-05-06 17:49

reporter   ~0002441

Yes. I do confirm that I had gnustep-* from epel (it has the same version and release, but it win in resolver, due to dist tag).

I do confirm that after removing, setting the exclude and installing again, this error disappear.

I see it is already documented at:
http://www.sogo.nu/english/support/faq/article/how-to-install-sogo-and-sope-through-yum-1.html
Nice work.

Issue History

Date Modified Username Field Change
2011-05-04 21:52 msuchy New Issue
2011-05-06 12:59 jraby Note Added: 0002434
2011-05-06 13:10 jraby Note Added: 0002435
2011-05-06 17:49 msuchy Note Added: 0002441
2011-05-06 20:32 jraby Assigned To => jraby
2011-05-06 20:32 jraby Status new => resolved
2017-01-06 19:57 francis Status resolved => closed