View Issue Details

IDProjectCategoryView StatusLast Update
0001238SOGoWeb Mailpublic2011-04-08 19:26
Reporterwimmer Assigned Toludovic  
Status resolvedResolutionfixed 
Product Versionnightly v2 
Target Version1.3.6Fixed in Version1.3.6 
Summary0001238: Cannot work with folders containing some characters with diacritical marks in their names

When name of the e-mail folders contains some characters with diacritical marks, webmail doesn't work with them. It doesn't show any messages of these folders, cannot delete or rename these folders, ...
I found this happens when name of the folder contains characters:
? ? š ? ? (maybe still others).

Here is log of renaming folder "?" to "newname":
localhost - - [06/Apr/2011:10:17:54 GMT] "POST /SOGo/so/harryp/Mail/0/folder%C5%99/renameFolder?name=newname HTTP/1.1" 500 24/0 0.323 - - 0

Needs to say I use setting of this variable in /etc/init.d/sogo :

and this variable in GNUstep defaults:
sogod NGUseUTF8AsURLEncoding YES

I use them from the "times of the old history". They are not mentioned in current documentation. Is it needed to use them in current versions or can I remove them?
I tried to remove both of them on my testing server just now, but it doesn't solve the problem.

TagsNo tags attached.




2011-04-07 15:46

administrator   ~0002338

Do you see errors such as this one in your log?

<pre>sogod [21536]: [ERROR] <0x0x8ff1208[NGImap4Connection]> could not select URL: (nil): (nil)</pre>



2011-04-07 15:51

reporter   ~0002339

Yes, I do:

Apr 07 17:49:27 sogod [24094]: [ERROR] <0x0x2a56c40[NGImap4Connection]> could not select URL: (nil): (nil)
localhost - - [07/Apr/2011:17:49:27 GMT] "POST /SOGo/so/harryp/Mail//0/folder%C5%99%C5%A1/uids HTTP/1.1" 200 2/28 0.470 - - 300K
Apr 07 17:49:27 sogod [24094]: [ERROR] <0x0x2b975a0[NGImap4Connection]> could not select URL: (nil): (nil)
localhost - - [07/Apr/2011:17:49:27 GMT] "POST /SOGo/so/harryp/Mail//0/folder%C5%99%C5%A1/unseenCount HTTP/1.1" 200 13/0 0.257 - - 4K
Apr 07 17:49:27 sogod [24094]: [ERROR] <0x0x275b120[NGImap4Connection]> could not select URL: (nil): (nil)
localhost - - [07/Apr/2011:17:49:27 GMT] "POST /SOGo/so/harryp/Mail//0/folder%C5%99%C5%A1/headers HTTP/1.1" 200 130/100 0.171 - - 0



2011-04-07 20:36

administrator   ~0002341

Can you try on ?

Also, can you try to add AddDefaultCharset UTF-8 to your Apache's SOGo.conf ?



2011-04-07 20:54

reporter   ~0002342

I cannot create/rename any new folder or sub-folder on the now.
But I found some folders with "critical" character "š" /s with crook/ in their names under sogo3 account and I see some messages inside of them. What doesn't work on my machines...

I'm using AddDefaultCharset UTF-8 in my Apache's SOGo.conf from beginning.



2011-04-07 20:57

administrator   ~0002343

How come you can't rename any new folder? Any JavaScript error?



2011-04-07 21:09

reporter   ~0002344

Firefox - I select "New Folder" or "Rename Folder" or "New Subfolder" and nothing happens. No dialog box is opened, no error on the Error Console.

Chrome - I select "New Folder" or "Rename Folder" or "New Subfolder", dialog box is opened, I type name - and no folder is created/renamed.

Epiphany - the same as Chrome.

This all I have on only.
It (create/rename commands) works fine on my both servers.



2011-04-07 21:16

reporter   ~0002345

Now I created new folder "ooo" in sogo2 account.
I tried to create new folder "šš" (I typed "šš" into dialog box) after it, but it was not created. Maybe you can find it in the log?



2011-04-07 21:24

viewer   ~0002346

Hi Milos,

Just an idea: are you forcing iso-8859-2 charset on the SOGo sites ?



2011-04-07 21:26

reporter   ~0002347

On my firefox (when dialog box is not opened) - I see on Console this error:
"Permission denied to access property 'clabels'"
in SOGo.woa/WebServerResources/generic.js:1699
function onHeaderClick(event)
if (topWindow && topWindow.clabels && topWindow.clabels[key])

It is the same on FF4.x on Linux and on FF3.6 on Windows.



2011-04-07 21:40

reporter   ~0002348

My browser shows "View -> Character Encoding -> UTF-8".

I'm using:
cs_CZ ISO-8859-2
cs_CZ.UTF-8 UTF-8
en_US.UTF-8 UTF-8
in /etc/locale.gen on sogo server

I'm using:
AddDefaultCharset UTF-8 in my Apache's SOGo.conf

When I create new folder "2š" from WebGUI, I see "2&AWE-" directory on my dovecot server.
When I create new folder "3š" from Thunderbird, I see "3&AWE-" directory on my dovecot server.
I can work without problem with both these folders from Thunderbird.
I cannot work with them from WebGUI
{sogod [27300]: [ERROR] <0x0x12eb15c0[NGImap4Connection]> could not select URL: (nil): (nil)}



2011-04-08 14:07

viewer   ~0002351

I found the bug.... You have probably configured your mail preferences to show only subscribed folders. For some reason, the creation of the folders works at first, but not the auto-subscription that follows. This means that the folder is properly created and when you try to recreate it, the operation will fail. It just does not show in the list.



2011-04-08 14:44

reporter   ~0002352

Fine, it could be case of trouble when I could not create folders on the server.

But I think it has no relation to bug reported in this track.
My "Preferences -> Mail Options -> Show subscribed mailboxes only" is not checked on any accounts where I'm trying it.
But for all cases - I compiled and installed current mtn just now and the problem continues.

When you will apply your fix to server, I can create folder "ššš" there and then you could move any message into it. Then you will see that WebGUI will not move it.



2011-04-08 14:59

reporter   ~0002353

BTW - I checked of "Show subscribed mailboxes only" setting on the sogo2 account on server now.
I see all folders (like "ššš") I created yesterday.
But -

  • I cannot rename any folder
  • I cannot move message to any folder

There is no action, no log on Error Console.

When you will be able to move any message to folder "Draft" (what works without problem on my servers), try move it to folder "ššš" (what doesn't work).




2011-04-08 15:40

administrator   ~0002354

This should be fixed with:

Please test with



2011-04-08 15:56

reporter   ~0002355

Hi Ludovic,
I applied your patch (sogo+sope) to my server and it solves the problem completely.
It works on too.

Thank you very much for your help.

Good luck with 1.3.6 ;-)



2011-04-08 16:25

administrator   ~0002356


Issue History

Date Modified Username Field Change
2011-04-06 09:21 wimmer New Issue
2011-04-07 15:46 francis Note Added: 0002338
2011-04-07 15:51 wimmer Note Added: 0002339
2011-04-07 20:36 ludovic Note Added: 0002341
2011-04-07 20:54 wimmer Note Added: 0002342
2011-04-07 20:57 ludovic Note Added: 0002343
2011-04-07 21:09 wimmer Note Added: 0002344
2011-04-07 21:16 wimmer Note Added: 0002345
2011-04-07 21:24 wsourdeau Note Added: 0002346
2011-04-07 21:26 wimmer Note Added: 0002347
2011-04-07 21:40 wimmer Note Added: 0002348
2011-04-08 14:07 wsourdeau Note Added: 0002351
2011-04-08 14:44 wimmer Note Added: 0002352
2011-04-08 14:59 wimmer Note Added: 0002353
2011-04-08 15:40 ludovic Note Added: 0002354
2011-04-08 15:56 wimmer Note Added: 0002355
2011-04-08 16:25 ludovic Note Added: 0002356
2011-04-08 16:25 ludovic Status new => resolved
2011-04-08 16:25 ludovic Fixed in Version => 1.3.6
2011-04-08 16:25 ludovic Resolution open => fixed
2011-04-08 16:25 ludovic Assigned To => ludovic
2011-04-08 19:26 ludovic Target Version => 1.3.6