View Issue Details

IDProjectCategoryView StatusLast Update
0000785SOGoBackend Calendarpublic2010-09-14 20:37
Reporterbertails Assigned Toludovic  
Status resolvedResolutionfixed 
Product Version1.3.0 
Target Version1.3.2Fixed in Version1.3.2 
Summary0000785: Modification rights on a shared calendar in iCal

== How to reproduce the bug ==

  • user A has a shared calendar with user B who has any modification or creation rights
  • B accesses A's calendar in iCal (tested with 4.0.3 version on Snow Leopard) as a delegate calendar

== Description of what happens ==

There is then this error showing up in iCal:
The server responded with an error.

Access to account "A" is not permitted.

The server responded:
"HTTP/1.1 403 Forbidden" to operation CalDAVAccountRefreshQueueableOperation.

If I click on "Ignore", it keeps showing the same error.

If I click on "Go Offline", I can actually access the events and even create or modify them. The problem is back as soon as iCal tries to refresh the calendar.

Here is what I see in sogo.log (yes, there is a weird access to some inbox):
[[ - - [27/Aug/2010:14:54:20 GMT] "PROPFIND /SOGo/dav/jeff/Calendar/ HTTP/1.1" 207 6294/862 0.020 - - 0 - - [27/Aug/2010:14:54:20 GMT] "PROPFIND /SOGo/dav/jeff/Calendar/inbox/ HTTP/1.1" 403 248/209 0.004 - - 0

I don't see any suspicious request in the LDAP.

Additional Information

I tried to access the calendar in Gnome/evolution and I don't have any issue.

TagsNo tags attached.




2010-08-27 19:12

reporter   ~0001389

Actually, I said something wrong: the modification or the creation of an event is not persisted.

So it means that SOGo does not work at all with delegate in iCal!



2010-09-14 20:37

administrator   ~0001449

Fixed with:

Issue History

Date Modified Username Field Change
2010-08-27 18:57 bertails New Issue
2010-08-27 19:12 bertails Note Added: 0001389
2010-09-01 23:36 ludovic Target Version => 1.3.2
2010-09-14 20:37 ludovic Note Added: 0001449
2010-09-14 20:37 ludovic Status new => resolved
2010-09-14 20:37 ludovic Fixed in Version => 1.3.2
2010-09-14 20:37 ludovic Resolution open => fixed
2010-09-14 20:37 ludovic Assigned To => ludovic