View Issue Details

IDProjectCategoryView StatusLast Update
0005847SOGoBackend Address Bookpublic2023-09-06 12:07
ReporterWaschbuesch Assigned Tosebastien  
Status resolvedResolutionno change required 
Platform[Client] AppleOSmacOSOS Version13.5 (Ventura)
Product Version5.8.3 
Summary0005847: macOS Contacts not seeing any address book in SOGo >=5.8.3

Using macOS 13 builtin address book app as CardDAV client, I can no longer
access contacts in my address book after upgrading SOGo to >= 5.8.3.

There are no errors in the logs as far as I can see, however, Apple's addressbook app will
show 0 contacts. They are still present via SOGo webmail and also using
Thunderbird (native, no connector) and K9 on my Android phone.

Steps To Reproduce

1.) Using SOGo => 5.8.3, log in as a user and ensure that SOGo's default address book exists.
2.) Add a contact to that address book.
3.) On macOS, configure that CardDAV account in Apple's Contacts app

Additional Information

I do not see errors in the logs, but I do not have debugging enabled.

Downgrading SOGo to 5.8.0 resolves the issue.

I also tried:

  • creating a new user in order to have a completely fresh SOGo profile
  • deleting and re-adding the account on macOS
Tagsaddressbook, CardDAV, contacts




2023-08-29 23:44

administrator   ~0017225

Can you try with nightly build ? Or at least with ?
This is issue should be resolved but I didn't had the time for testing this.




2023-08-30 03:52

reporter   ~0017226

I would try using the demo site. Unfortunately, right now (Mi 30 Aug 2023 03:48:00 UTC), it seems to be down (see screenshot).
I can also try with nightly - will take some more time though - or I can wait for the next release? (199,608 bytes) (199,608 bytes)   


2023-08-30 09:20

reporter   ~0017227 working again, I tried, but in vain.

I added a contact to the sogo3 user, but that did not get displayed in the Contacts app.
I added another contact locally, but that did not get uploaded.



2023-09-06 08:53

administrator   ~0017241

Hi @Waschbuesch,

After some tests, I can add/edit/remove contacts on (check screenshots in attachements).
Synchronization can take some time but this is related to Apple's internal mechanism.




2023-09-06 10:23

reporter   ~0017242

It still did not work for me, I then tried creating a new macOS account and created the CardDAV account there.
With that, syncing worked! I have no idea why, but for now, I guess you can close the ticket.

Thank you for your help!

Issue History

Date Modified Username Field Change
2023-08-28 16:41 Waschbuesch New Issue
2023-08-28 16:41 Waschbuesch Tag Attached: addressbook
2023-08-28 16:41 Waschbuesch Tag Attached: CardDAV
2023-08-28 16:41 Waschbuesch Tag Attached: contacts
2023-08-29 23:44 sebastien Note Added: 0017225
2023-08-30 03:52 Waschbuesch Note Added: 0017226
2023-08-30 03:52 Waschbuesch File Added:
2023-08-30 09:20 Waschbuesch Note Added: 0017227
2023-09-04 07:01 sebastien Assigned To => sebastien
2023-09-04 07:01 sebastien Status new => assigned
2023-09-06 08:53 sebastien Note Added: 0017241
2023-09-06 08:53 sebastien File Added: Capture d’écran 2023-09-06 à 10.49.32.png
2023-09-06 08:53 sebastien File Added: Capture d’écran 2023-09-06 à 10.49.54.png
2023-09-06 08:53 sebastien File Added: Capture d’écran 2023-09-06 à 10.50.47.png
2023-09-06 08:53 sebastien Status assigned => feedback
2023-09-06 10:23 Waschbuesch Note Added: 0017242
2023-09-06 10:23 Waschbuesch Status feedback => assigned
2023-09-06 12:07 sebastien Status assigned => resolved
2023-09-06 12:07 sebastien Resolution open => no change required