Dependency Graph

Dependency Graph
related to related to child of child of duplicate of duplicate of

View Issue Details

IDProjectCategoryView StatusLast Update
0000605SOGoBackend Generalpublic2010-06-17 18:25
ReporterDavid Assigned Tofrancis  
Status resolvedResolutionfixed 
Product Version1.2.1 
Target Version1.3.0Fixed in Version1.3.0 
Summary0000605: memcached package preventing libevent update on RHEL5

Package memcached-1.4.2-1.el5.x86_64 from SOGo repository is preventing update of libevent package from rhel-x86_64-server-5 repository.

Additional Information

New libevent package (libevent-1.4.13-1) is providing updated version of libevent library ( but provided memcached package is compiled with version.

Looks like newer memcached package (or some kind of compat-libevent package) needs to be placed in the repo.

TagsNo tags attached.


has duplicate 0000636 closed [SOGO] libevent and memcached dependancies error 


2010-05-05 09:06


yum-update.log (928 bytes)


2010-05-17 20:38

administrator   ~0001021

Are you sure the memcached package isn't been pulled from an other repository than the one from SOGo?

I've just done a fresh install on CentOS 5.4/x86_64 with no issue.




2010-05-18 06:37

reporter   ~0001022

I hit the same error with the memcached from the epel repository.
It should be fixed now as Centos 5.5 was released.


Not a SOGo bug though.



2010-05-18 12:58

reporter   ~0001023

Last edited: 2010-05-18 12:59

on Centos 5.5 i got:

yum install sogo

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • addons:
  • base:
  • extras:
  • updates:
    RHEL5 | 1.9 kB 00:00
    addons | 951 B 00:00
    base | 1.1 kB 00:00
    extras | 2.1 kB 00:00
    updates | 1.9 kB 00:00
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package sogo.i386 0:1.2.2-1.el5 set to be updated
    --> Processing Dependency: memcached for package: sogo
    --> Running transaction check
    ---> Package memcached.i386 0:1.4.2-1.el5 set to be updated
    --> Processing Dependency: for package: memcached
    --> Finished Dependency Resolution
    memcached-1.4.2-1.el5.i386 from RHEL5 has depsolving problems
    --> Missing Dependency: is needed by package memcached-1.4.2-1.el5.i386 (RHEL5)
    Error: Missing Dependency: is needed by package memcached-1.4.2-1.el5.i386 (RHEL5)


2010-05-18 13:09

administrator   ~0001024

Try to exclude the memcached package from other repos so that the one from SOGo is correctly pulled.



2010-05-18 13:22

reporter   ~0001025

i did that, same error
memcached-1.4.2-1.el5.i386 <- seems the sogo version
but there is no libevent in the sogo repo



2010-05-18 21:41

reporter   ~0001032

Excluding doesn't work because the packages of the SOGo-Repo are to old!

The Spec-File of the SRPMS should also be fixed! There must be a dependency statement like:

Requires: libevent >= 1.1a (or something this way)

Problem is the following:
Redhat/CentOS 5.5 has updated libevent from 1.1a to 1.4.13-1 but the version in the the SOGo-Repo is too old and requires 1.1a.

You can check this with:
rpm -qpR memcached-1.4.2-1.el5.x86_64.rpm

config(memcached) = 1.4.2-1.el5
initscripts <--- This is the version which the SOGo package wants


  1. Recompile SRPMS with Redhat/CentOS 5.5 and the problem is gone
  2. Better: Fix the missing Dependency with a Requires-Statement in the SPEC-File of the SRPMS.


2010-05-19 07:43

reporter   ~0001037

New libevent package comes with 5.5 update - that's probably why fresh install on CentOS 5.4/x86_64 had no issue.



2010-05-25 14:55

reporter   ~0001055

any updates ? the solution has been posted..
or do i need to reinstall CentOS 5.4 ?



2010-05-25 19:41

reporter   ~0001057

rebuild by hand:

  • download SRPMS
  • build:_rpmbuild --rebuild <srpms-file>
  • install new rpm: rpm -Uvh <rpm-file>

then edit SOGo.repo and add "exclude=memcached*".

Now you can update as always with "yum update".



2010-06-17 18:25

administrator   ~0001115

Fixed for the nightly repository (i386+x86_64).

With respect to the dependencies on SOPE and SOGo:

  • The Inverse repository provides the GNUstep and libmemcached packages;
  • The CentOS/RHEL repository provides libevent;
  • RPMForge[1] provides libffi and memcached.


Issue History

Date Modified Username Field Change
2010-05-05 09:06 David New Issue
2010-05-05 09:06 David File Added: yum-update.log
2010-05-17 20:38 ludovic Note Added: 0001021
2010-05-18 06:37 julien Note Added: 0001022
2010-05-18 12:58 MSmiatek Note Added: 0001023
2010-05-18 12:59 MSmiatek Note Edited: 0001023
2010-05-18 13:09 ludovic Note Added: 0001024
2010-05-18 13:22 MSmiatek Note Added: 0001025
2010-05-18 21:41 wcronen Note Added: 0001032
2010-05-19 07:43 David Note Added: 0001037
2010-05-25 14:55 MSmiatek Note Added: 0001055
2010-05-25 19:41 wcronen Note Added: 0001057
2010-06-11 01:03 ludovic Target Version => 1.2.3
2010-06-11 19:04 wsourdeau Status new => assigned
2010-06-11 19:04 wsourdeau Assigned To => wsourdeau
2010-06-11 19:04 wsourdeau Relationship added has duplicate 0000636
2010-06-11 19:47 wsourdeau Assigned To wsourdeau => francis
2010-06-17 18:25 francis Note Added: 0001115
2010-06-17 18:25 francis Status assigned => resolved
2010-06-17 18:25 francis Fixed in Version => 1.3.0
2010-06-17 18:25 francis Resolution open => fixed